当前位置: 海之晶网站设计> 建站知识> 常见问题>用现代PHP改进WordPress代码

用现代PHP改进WordPress代码

文章出处:网站建设-海之晶网络 | 网站编辑:网站设计 | 发表时间:2020/9/9 13:18:47
分享:

WordPress诞生于15年前,由于其历史上一直保持向后兼容性,其代码的较新版本无法充分利用较新版本的PHP提供的最新功能。虽然PHP的最新版本是7.3.2,但WordPress仍然支持php5.2.4。

但是那些日子很快就会过去!WordPress将升级其最低PHP版本支持,2019年4月升级到PHP5.6,2019年12月升级到PHP7(如果一切按计划进行)。然后,我们就可以开始使用PHP的命令式编程功能,而不用担心会破坏客户的网站。万岁!

由于WordPress十五年的功能代码影响了开发人员如何使用WordPress进行构建,因此我们的网站、主题和插件中可能会充斥着一些不太理想的代码,这些代码可以很好地接受升级。

本文由两部分组成:

关键字:
南京市汉中路1号国际金融中心9楼
建站热线:13815417591
免责声明: 本站部分内容来源于互联网,如果本站部分内容侵犯您的权益,请您告知,站长会立即处理。